using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @";(?=[^[]*])";
string substitution = @",";
string input = @"[""Text1;Text2;....;TextN""];asjkdjksd;ajksdjksad[""Text1;Text2;....;TextN""]
.[""Text1;Text2""]...long text...[""Text1;Text2;Text3""]....long text...[""Text1;...;TextN""]...long text...
I ONLY want to change the "";"" in the [""Text1;...;TextN""]";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}