package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:\d\s*){10}(?:(?:\d\s*){3})?`)
var str = `2442141411
One 2 442141411 two 24 42141411 three
2 44214141 1
2 6 9 32 2 3 8 376 67
2 6 9 32 2 3 87 77 67 8
2 6 9 32 2 3 8 37667
2442141411 123
2442141411 1
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}