re = /(?:\d\s*){10}(?:(?:\d\s*){3})?/m
str = '2442141411
One 2 442141411 two 24 42141411 three
2 44214141 1
2 6 9 32 2 3 8 376 67
2 6 9 32 2 3 87 77 67 8
2 6 9 32 2 3 8 37667
2442141411 123
2442141411 1
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end