import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:\\d\\s*){10}(?:(?:\\d\\s*){3})?";
final String string = "2442141411\n"
+ "One 2 442141411 two 24 42141411 three\n"
+ "2 44214141 1\n"
+ " 2 6 9 32 2 3 8 376 67\n"
+ "2 6 9 32 2 3 87 77 67 8\n"
+ "2 6 9 32 2 3 8 37667\n"
+ "2442141411 123\n"
+ "2442141411 1\n\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}