use strict;
my $str = '2442141411
One 2 442141411 two 24 42141411 three
2 44214141 1
2 6 9 32 2 3 8 376 67
2 6 9 32 2 3 87 77 67 8
2 6 9 32 2 3 8 37667
2442141411 123
2442141411 1
';
my $regex = qr/(?:\d\s*){10}(?:(?:\d\s*){3})?/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}