#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "}(.|\n)*?}"
Local $sString = "adsasdassdasdfff }" & @CRLF & _
"qualquer texto, com arumentos escapados como á â , . A B C 0 9 [ ] \n ; ~ ^ - = ' " !@#$%¨¨&**( e quebra de linha" & @CRLF & _
"}" & @CRLF & _
"asdasdasasdsa" & @CRLF & _
"eeeee " & @CRLF & _
"{" & @CRLF & _
"aaaaaa" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")