$re = '/}(.|\n)*?}/';
$str = 'adsasdassdasdfff }
qualquer texto, com arumentos escapados como á â , . A B C 0 9 [ ] \\n ; ~ ^ - = \' " !@#$%¨¨&**( e quebra de linha
}
asdasdasasdsa
eeeee
{
aaaaaa
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);