import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\}(.|\\n)*?\\}";
final String string = "adsasdassdasdfff }\n"
+ "qualquer texto, com arumentos escapados como á â , . A B C 0 9 [ ] \\n ; ~ ^ - = ' \" !@#$%¨¨&**( e quebra de linha\n"
+ "}\n"
+ "asdasdasasdsa\n"
+ "eeeee \n"
+ "{\n"
+ "aaaaaa\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}