#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?=.*\d)(?=.*[a-z])(?=.*[A-Z])(?=.*[~@#^*\-_+\[{}\]:./?])(?!.*(.)(\1\1))[\w~@#^*\-_+\[{}\]:./?!]{8,64}$"
Local $sString = "Password_pass" & @CRLF & _
"PASSWORD_123" & @CRLF & _
"Password123" & @CRLF & _
"Password_123" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"Password_123" & @CRLF & _
"Password_1233" & @CRLF & _
"Password_12333" & @CRLF & _
"Password__123" & @CRLF & _
"Password___123" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"Password#123" & @CRLF & _
"Password~123" & @CRLF & _
"Password?[]123" & @CRLF & _
"" & @CRLF & _
"Pa_1234" & @CRLF & _
"Pa_12345" & @CRLF & _
"Pa_0123456789012345678901234567890123456789012345678901234567890" & @CRLF & _
"Pa_01234567890123456789012345678901234567890123456789012345678901"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")