const regex = new RegExp('^(?=.*\\d)(?=.*[a-z])(?=.*[A-Z])(?=.*[~@#^*\\-_+\\[{}\\]:./?])(?!.*(.)(\\1\\1))[\\w~@#^*\\-_+\\[{}\\]:./?!]{8,64}$', 'gm')
const str = `Password_pass
PASSWORD_123
Password123
Password_123
Password_123
Password_1233
Password_12333
Password__123
Password___123
Password#123
Password~123
Password?[]123
Pa_1234
Pa_12345
Pa_0123456789012345678901234567890123456789012345678901234567890
Pa_01234567890123456789012345678901234567890123456789012345678901`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}