import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?=.*\\d)(?=.*[a-z])(?=.*[A-Z])(?=.*[~@#^*\\-_+\\[\\{\\}\\]:./?])(?!.*(.)(\\1\\1))[\\w~@#^*\\-_+\\[\\{\\}\\]:./?!]{8,64}$";
final String string = "Password_pass\n"
+ "PASSWORD_123\n"
+ "Password123\n"
+ "Password_123\n\n\n"
+ "Password_123\n"
+ "Password_1233\n"
+ "Password_12333\n"
+ "Password__123\n"
+ "Password___123\n\n\n"
+ "Password#123\n"
+ "Password~123\n"
+ "Password?[]123\n\n"
+ "Pa_1234\n"
+ "Pa_12345\n"
+ "Pa_0123456789012345678901234567890123456789012345678901234567890\n"
+ "Pa_01234567890123456789012345678901234567890123456789012345678901";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}