#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(.*) (?:\[(.*)] )?\((.*) (.*) \[(.*)]"
Local $sString = "netplan.io [0.36.3] (0.40.1~18.04.3 Ubuntu:18.04/bionic-updates [amd64])" & @CRLF & _
"nplan (0.40.1~18.04.3 Ubuntu:18.04/bionic-updates [all])"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")