$re = '/(.*) (?:\[(.*)] )?\((.*) (.*) \[(.*)]/m';
$str = 'netplan.io [0.36.3] (0.40.1~18.04.3 Ubuntu:18.04/bionic-updates [amd64])
nplan (0.40.1~18.04.3 Ubuntu:18.04/bionic-updates [all])';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);