re = /(.*) (?:\[(.*)] )?\((.*) (.*) \[(.*)]/m
str = 'netplan.io [0.36.3] (0.40.1~18.04.3 Ubuntu:18.04/bionic-updates [amd64])
nplan (0.40.1~18.04.3 Ubuntu:18.04/bionic-updates [all])'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end