const regex = /(.*) (?:\[(.*)] )?\((.*) (.*) \[(.*)]/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(.*) (?:\\[(.*)] )?\\((.*) (.*) \\[(.*)]', 'gm')
const str = `netplan.io [0.36.3] (0.40.1~18.04.3 Ubuntu:18.04/bionic-updates [amd64])
nplan (0.40.1~18.04.3 Ubuntu:18.04/bionic-updates [all])`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}