import re
regex = re.compile(r"(.*) (?:\[(.*)] )?\((.*) (.*) \[(.*)]", flags=re.MULTILINE)
test_str = ("netplan.io [0.36.3] (0.40.1~18.04.3 Ubuntu:18.04/bionic-updates [amd64])\n"
"nplan (0.40.1~18.04.3 Ubuntu:18.04/bionic-updates [all])")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")