using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\/\w+\/\w+)((\/?$)|(\?.+$))";
string input = @"http://www.meusite.com/api/content/edit
http://www.meusite.com/api/content2/edit/
http://www.meusite.com/api/content/edit?q=
http://www.meusite.com/api/content/edit?q=texto
http://www.meusite.com/api/content/edit?q=123321
http://www.meusite.com/api/content/edit?q=123321&outroparametro=432";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}