package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\/\w+\/\w+)((\/?$)|(\?.+$))`)
var str = `http://www.meusite.com/api/content/edit
http://www.meusite.com/api/content2/edit/
http://www.meusite.com/api/content/edit?q=
http://www.meusite.com/api/content/edit?q=texto
http://www.meusite.com/api/content/edit?q=123321
http://www.meusite.com/api/content/edit?q=123321&outroparametro=432`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}