$re = '/(\/\w+\/\w+)((\/?$)|(\?.+$))/m';
$str = 'http://www.meusite.com/api/content/edit
http://www.meusite.com/api/content2/edit/
http://www.meusite.com/api/content/edit?q=
http://www.meusite.com/api/content/edit?q=texto
http://www.meusite.com/api/content/edit?q=123321
http://www.meusite.com/api/content/edit?q=123321&outroparametro=432';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);