import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\/\\w+\\/\\w+)((\\/?$)|(\\?.+$))";
final String string = "http://www.meusite.com/api/content/edit\n"
+ "http://www.meusite.com/api/content2/edit/\n"
+ "http://www.meusite.com/api/content/edit?q=\n"
+ "http://www.meusite.com/api/content/edit?q=texto\n"
+ "http://www.meusite.com/api/content/edit?q=123321\n"
+ "http://www.meusite.com/api/content/edit?q=123321&outroparametro=432";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}