import Foundation
let pattern = #"(\/\w+\/\w+)((\/?$)|(\?.+$))"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
http://www.meusite.com/api/content/edit
http://www.meusite.com/api/content2/edit/
http://www.meusite.com/api/content/edit?q=
http://www.meusite.com/api/content/edit?q=texto
http://www.meusite.com/api/content/edit?q=123321
http://www.meusite.com/api/content/edit?q=123321&outroparametro=432
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)