using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?! )(?!.* $)(?=.*[a-zA-Z])[^#+\\,\n]+$";
string input = @"dfg
rt534
34dfg
dfg 564 dfg545
!sdf7&*
445fsdf
4
345
dffs
sdfsdf
#df8
sdfsdf,4534
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}