$re = '/^(?! )(?!.* $)(?=.*[a-zA-Z])[^#+\\\\,\n]+$/m';
$str = 'dfg
rt534
34dfg
dfg 564 dfg545
!sdf7&*
445fsdf
4
345
dffs
sdfsdf
#df8
sdfsdf,4534
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);