re = /^(?! )(?!.* $)(?=.*[a-zA-Z])[^#+\\,\n]+$/m
str = 'dfg
rt534
34dfg
dfg 564 dfg545
!sdf7&*
445fsdf
4
345
dffs
sdfsdf
#df8
sdfsdf,4534
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end