const regex = /^(?! )(?!.* $)(?=.*[a-zA-Z])[^#+\\,\n]+$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?! )(?!.* $)(?=.*[a-zA-Z])[^#+\\\\,\\n]+$', 'gm')
const str = `dfg
rt534
34dfg
dfg 564 dfg545
!sdf7&*
445fsdf
4
345
dffs
sdfsdf
#df8
sdfsdf,4534
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}