import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?! )(?!.* $)(?=.*[a-zA-Z])[^#+\\\\,\\n]+$";
final String string = "dfg\n"
+ "rt534\n"
+ "34dfg\n"
+ "dfg 564 dfg545\n"
+ "!sdf7&*\n"
+ "445fsdf\n"
+ "4\n"
+ "345\n"
+ " dffs\n"
+ "sdfsdf \n"
+ "#df8\n"
+ "sdfsdf,4534\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}