#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?i)(\W|^)[\w.\-]{128}(\W|$)"
Local $sString = "8ec15d43c0bb01eca1c278c61b3dc73d844a19a22466647191786bae74ac0ae54f957cc8be7fd9a5b8fbbb41948429fe69bc1255df84fae885cad3e10ecefd36"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")