$re = '/(?i)(\W|^)[\w.\-]{128}(\W|$)/m';
$str = '8ec15d43c0bb01eca1c278c61b3dc73d844a19a22466647191786bae74ac0ae54f957cc8be7fd9a5b8fbbb41948429fe69bc1255df84fae885cad3e10ecefd36';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);