import Foundation
let pattern = #"(?i)(\W|^)[\w.\-]{128}(\W|$)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"8ec15d43c0bb01eca1c278c61b3dc73d844a19a22466647191786bae74ac0ae54f957cc8be7fd9a5b8fbbb41948429fe69bc1255df84fae885cad3e10ecefd36"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)