const regex = /(?i)(\W|^)[\w.\-]{128}(\W|$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?i)(\\W|^)[\\w.\\-]{128}(\\W|$)', 'gm')
const str = `8ec15d43c0bb01eca1c278c61b3dc73d844a19a22466647191786bae74ac0ae54f957cc8be7fd9a5b8fbbb41948429fe69bc1255df84fae885cad3e10ecefd36`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}