import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?i)(\\W|^)[\\w.\\-]{128}(\\W|$)";
final String string = "8ec15d43c0bb01eca1c278c61b3dc73d844a19a22466647191786bae74ac0ae54f957cc8be7fd9a5b8fbbb41948429fe69bc1255df84fae885cad3e10ecefd36";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}