# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(\d{5})-\d{4}$/$1/gm;t' <<< "94107-1532
94107-1532
94107-1535
94107-1511"