using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(\d{5})-\d{4}$";
string substitution = @"$1";
string input = @"94107-1532
94107-1532
94107-1535
94107-1511";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}