re = /^(\d{5})-\d{4}$/m
str = '94107-1532
94107-1532
94107-1535
94107-1511'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result