use strict;
my $str = '94107-1532
94107-1532
94107-1535
94107-1511';
my $regex = qr/^(\d{5})-\d{4}$/mp;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";