package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`https:\/\/youtu\.be\/([a-zA-Z0-9_-]+)`)
var str = `https://youtu.be/KkcrQTqr9q4`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}