re = /https:\/\/youtu\.be\/([a-zA-Z0-9_-]+)/
str = 'https://youtu.be/KkcrQTqr9q4'
# Print the match result
str.match(re) do |match|
puts match.to_s
end