$re = '/https:\/\/youtu\.be\/([a-zA-Z0-9_-]+)/';
$str = 'https://youtu.be/KkcrQTqr9q4';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);