import Foundation
let pattern = #"https:\/\/youtu\.be\/([a-zA-Z0-9_-]+)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"https://youtu.be/KkcrQTqr9q4"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}