const regex = /https:\/\/youtu\.be\/([a-zA-Z0-9_-]+)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('https:\\\/\\\/youtu\\.be\\\/([a-zA-Z0-9_-]+)', '')
const str = `https://youtu.be/KkcrQTqr9q4`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}