import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([-+]?\\d\\d+[.]\\d+)\\s?,?([-+]?\\d+[.]\\d+)";
final String string = "q=27.622063,-80.388802\n\n"
+ "https://maps.google.com/maps?q=27.622063,-80.388802&hl=es&z=12&output=embed\n\n"
+ "https://maps.google.com/maps?q=33.5805955,-112.23737790000001&hl=es&z=12&output=embed\n\n"
+ "https://maps.google.com/maps?q=36.23961479999999,-75.8754505&hl=es&z=12&output=embed\n\n"
+ "https://maps.google.com/maps?q=38.9671035,-78.1911207&hl=es&z=12&output=embed\n\n"
+ "/@([0-9\\.]+),([0-9\\.]+),([0-9z]+)/\n\n"
+ "([-+]?\\d\\d+[.]\\d+)\\s?,?([-+]?\\d+[.]\\d+)";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}