import re
regex = re.compile(r"([-+]?\d\d+[.]\d+)\s?,?([-+]?\d+[.]\d+)", flags=re.MULTILINE)
test_str = ("q=27.622063,-80.388802\n\n"
"https://maps.google.com/maps?q=27.622063,-80.388802&hl=es&z=12&output=embed\n\n"
"https://maps.google.com/maps?q=33.5805955,-112.23737790000001&hl=es&z=12&output=embed\n\n"
"https://maps.google.com/maps?q=36.23961479999999,-75.8754505&hl=es&z=12&output=embed\n\n"
"https://maps.google.com/maps?q=38.9671035,-78.1911207&hl=es&z=12&output=embed\n\n"
"/@([0-9\\.]+),([0-9\\.]+),([0-9z]+)/\n\n"
"([-+]?\\d\\d+[.]\\d+)\\s?,?([-+]?\\d+[.]\\d+)")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")