const regex = /([-+]?\d\d+[.]\d+)\s?,?([-+]?\d+[.]\d+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([-+]?\\d\\d+[.]\\d+)\\s?,?([-+]?\\d+[.]\\d+)', 'gm')
const str = `q=27.622063,-80.388802
https://maps.google.com/maps?q=27.622063,-80.388802&hl=es&z=12&output=embed
https://maps.google.com/maps?q=33.5805955,-112.23737790000001&hl=es&z=12&output=embed
https://maps.google.com/maps?q=36.23961479999999,-75.8754505&hl=es&z=12&output=embed
https://maps.google.com/maps?q=38.9671035,-78.1911207&hl=es&z=12&output=embed
/@([0-9\\.]+),([0-9\\.]+),([0-9z]+)/
([-+]?\\d\\d+[.]\\d+)\\s?,?([-+]?\\d+[.]\\d+)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}