re = /([-+]?\d\d+[.]\d+)\s?,?([-+]?\d+[.]\d+)/m
str = 'q=27.622063,-80.388802
https://maps.google.com/maps?q=27.622063,-80.388802&hl=es&z=12&output=embed
https://maps.google.com/maps?q=33.5805955,-112.23737790000001&hl=es&z=12&output=embed
https://maps.google.com/maps?q=36.23961479999999,-75.8754505&hl=es&z=12&output=embed
https://maps.google.com/maps?q=38.9671035,-78.1911207&hl=es&z=12&output=embed
/@([0-9\\.]+),([0-9\\.]+),([0-9z]+)/
([-+]?\\d\\d+[.]\\d+)\\s?,?([-+]?\\d+[.]\\d+)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end