#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)[^x](x{3}|x{5})[^x]"
Local $sString = "xxxxx" & @CRLF & _
"xxxx xxxxx xxx" & @CRLF & _
"xx xxxxx xx xxx" & @CRLF & _
"xxxxxx" & @CRLF & _
"xxx"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")