using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[^x](x{3}|x{5})[^x]";
string input = @"xxxxx
xxxx xxxxx xxx
xx xxxxx xx xxx
xxxxxx
xxx";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}