$re = '/[^x](x{3}|x{5})[^x]/m';
$str = 'xxxxx
xxxx xxxxx xxx
xx xxxxx xx xxx
xxxxxx
xxx';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);