// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)[^x](x{3}|x{5})[^x]").unwrap();
let string = "xxxxx
xxxx xxxxx xxx
xx xxxxx xx xxx
xxxxxx
xxx";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}