re = /[^x](x{3}|x{5})[^x]/m
str = 'xxxxx
xxxx xxxxx xxx
xx xxxxx xx xxx
xxxxxx
xxx'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end