#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?xiJ)\[" & @CRLF & _
" (?<tag>\w+) \s*" & @CRLF & _
" (?:=\s*" & @CRLF & _
" (?:" & @CRLF & _
" (?<quote>["']) (?<arg>.{0,100}?) \k<quote>" & @CRLF & _
" | (?<arg>[^\]]+)" & @CRLF & _
" )" & @CRLF & _
" )?" & @CRLF & _
"\]" & @CRLF & _
"" & @CRLF & _
"(?<content>" & @CRLF & _
" (?:[^[]++ | (?R) )*+" & @CRLF & _
")" & @CRLF & _
"" & @CRLF & _
"\[/\k<tag>\]"
Local $sString = "[spoiler]content[/spoiler], [spoiler=option]content[/spoiler] and [spoiler="option"]content[/spoiler]" & @CRLF & _
"" & @CRLF & _
"[a] foo [b] bar [/b] baz [/a]" & @CRLF & _
"[a=foo] foo [b] bar [/b] baz [/a]" & @CRLF & _
"[a="foo"] foo [b] bar [/b] baz [/a]" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")